【每日算法】基础算法——Dijkstra求最短路1(四十四)

题目内容

给定一个n个点m条边的有向图,图中可能存在重边和自环,所有边权均为正值。

请你求出1号点到n号点的最短距离,如果无法从1号点走到n号点,则输出-1。

输入格式

第一行包含整数n和m。

接下来m行每行包含三个整数x,y,z,表示存在一条从点x到点y的有向边,边长为z。

输出格式

输出一个整数,表示1号点到n号点的最短距离。

如果路径不存在,则输出-1。

数据范围

1≤n≤500 ,
1≤m≤10^5,
图中涉及边长均不超过10000。

输入样例

3 3
1 2 2
2 3 1
1 3 4

输出样例

3

题解

本题考查迪杰斯特拉算法。
一般朴素的迪杰斯特拉算法的思路如下:
Step 1:初始化s(代表当前已确定最短距离的点),同时初始化距离,dist[1] = 0, dist[i] = +∞ //一号点距离为0,其他点距离为无穷大
Step 2:for i:0->n:
t <- 不在s中的,距离最近的点
s <- t
用t更新其他点的距离:dist[x] > dist[t] + w

由于该题展示的图是一种稠密图,用邻接矩阵存比较合适。如果是稀疏图用邻接表存比较合适。
另外,代码中采用0x3f3f3f3f作为无穷大的定义,这里有一些解释,仅供参考。

代码

#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;

const int N = 510;

int n, m;
int g[N][N];
int dist[N]; //表示各点到1号点的距离
bool st[N]; //表示每个点是否已经确定最短路,是一个标识数组

int dijkstra(){
memset(dist, 0x3f, sizeof dist);
dist[1] = 0;

for(int i = 0; i < n; i++){
int t = -1;
for(int j = 1; j <=n; j++)
if(!st[j] && (t == -1 || dist[t] > dist[j]))
t = j;
st[t] = true;

for(int j = 1; j<= n; j++){
dist[j] = min(dist[j], dist[t] + g[t][j]);
}
}
if (dist[n] == 0x3f3f3f3f) return -1;
return dist[n];
}

int main(){
scanf("%d%d", &n, &m);

memset(g, 0x3f, sizeof g);

while(m --){
int a, b, c;
scanf("%d%d%d", &a, &b, &c);
g[a][b] = min(g[a][b], c);
}
int t = dijkstra();
printf("%d\n", t);
return 0;
}
Author: Frederic Niu
Link: https://www.fredericniu.cn/2021/01/25/【每日算法】基础算法——Dijkstra求最短路1(四十四)/
Copyright Notice: All articles in this blog are licensed under CC BY-NC-SA 4.0 unless stating additionally.
我的公众号