【每日算法】基础算法——SPFA判断负环(四十八)

题目内容

给定一个n个点m条边的有向图,图中可能存在重边和自环, 边权可能为负数。

请你判断图中是否存在负权回路。

输入格式

第一行包含整数n和m。

接下来m行每行包含三个整数x,y,z,表示存在一条从点x到点y的有向边,边长为z。

输出格式

如果图中存在负权回路,则输出“Yes”,否则输出“No”。

数据范围

1≤n≤2000 ,
1≤m≤10000,
图中涉及边长绝对值均不超过10000。

输入样例

3 3
1 2 -1
2 3 4
3 1 -4

输出样例

Yes

题解

在这个算法中,cnt[N]数组存储目前经过某点的边数。假设一共n个点,当cnt数组经过x点后,对应边数≥n,那么意味着从1到x经过了至少n条边,也就至少经过了n+1个点,根据抽屉原理,路径有n+1个点,因此一定有两个点值相同,因此一定存在对应该点的自环,又因为如果该边权重大于0,那么算法不可能接收此边入cnt中,因此该自环一定是负权回路,由此进行判断图中是否存在。

代码

#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>

using namespace std;

typedef pair<int, int> PII;

const int N = 100010;

int n,m;
int h[N], w[N], e[N], ne[N], idx;
int dist[N], cnt[N];
bool st[N];

void add(int a, int b, int c){
e[idx] = b, w[idx] = c; ne[idx] = h[a], h[a] = idx++;
}

int spfa(){
queue<int> q;

for(int i = 1; i<=n; i++){
st[i] = true;
q.push(i);
}


while(q.size()){
int t =q.front();
q.pop();
st[t] = false;
for(int i = h[t];i != -1; i = ne[i]){
int j =e[i];
if(dist[j] > dist[t] + w[i]){
dist[j] = dist[t] + w[i];
cnt[j] = cnt[t] + 1;
if(cnt[j] >= n) return true;
if(!st[j]){
q.push(j);
st[j] = true;
}
}
}
}


return false;

}

int main(){
scanf("%d%d", &n,&m);

memset(h, -1, sizeof h);

while(m --){
int a, b, c;
scanf("%d%d%d", &a, &b, &c);
add(a,b,c);
}

if (spfa()) puts("Yes");
else printf("No");

return 0;
}
Author: Frederic Niu
Link: https://www.fredericniu.cn/2021/01/27/【每日算法】基础算法——SPFA判断负环(四十八)/
Copyright Notice: All articles in this blog are licensed under CC BY-NC-SA 4.0 unless stating additionally.
我的公众号